Back to overview
Degraded

Cloud Service Disruptions

Jun 12 at 02:48pm CDT
Affected services
Anthology Student
Star Rez
Student Portal

Resolved
Jun 12 at 05:49pm CDT

All Clear

Created
Jun 12 at 02:48pm CDT

We are currently experiencing university-wide disruptions related to external cloud services, specifically Google Cloud and Amazon Web Services (AWS). These issues may be impacting access to various systems and applications across all programs. Our IT team is actively monitoring the situation and working with service providers to restore full functionality as soon as possible.

We appreciate your patience and will provide updates as more information becomes available.